$re = '/(?<property>[\w-]+[^:]): | (?<HEX_COLOR>#[0-9a-f]{3,8})/mud';
$str = '
.eight input[type=\'radio\']:checked + label {
color: #888;
background-color: hsla(8, 8%, 8%, 0.8);
}
.nine {
background: conic-gradient(
#ff9 0.25turn,
#009 0.25turn 0.5turn,
#999 0.5turn 0.75turn,
#900 0.75turn
) top left / 25% 25% repeat;
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);