import Foundation
// WARNING: You included a flag that Swift doesn't support: u
// When this flag is set, it makes the pattern and subject strings to be treated as unicode.
// Swift already treats the pattern and subject strings as unicode by default, so including this flag is redundant.
let pattern = ##"(?<property>[\w-]+[^:]): | (?<HEX_COLOR>#[0-9a-f]{3,8})"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
.eight input[type='radio']:checked + label {
color: #888;
background-color: hsla(8, 8%, 8%, 0.8);
}
.nine {
background: conic-gradient(
#ff9 0.25turn,
#009 0.25turn 0.5turn,
#999 0.5turn 0.75turn,
#900 0.75turn
) top left / 25% 25% repeat;
}
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)