// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mu)(?<property>[\w-]+[^:]): | (?<HEX_COLOR>#[0-9a-f]{3,8})").unwrap();
let string = "
.eight input[type='radio']:checked + label {
color: #888;
background-color: hsla(8, 8%, 8%, 0.8);
}
.nine {
background: conic-gradient(
#ff9 0.25turn,
#009 0.25turn 0.5turn,
#999 0.5turn 0.75turn,
#900 0.75turn
) top left / 25% 25% repeat;
}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}