const regex = /(?<property>[\w-]+[^:]): | (?<HEX_COLOR>#[0-9a-f]{3,8})/gmud;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<property>[\\w-]+[^:]): | (?<HEX_COLOR>#[0-9a-f]{3,8})', 'gmud')
const str = `
.eight input[type='radio']:checked + label {
color: #888;
background-color: hsla(8, 8%, 8%, 0.8);
}
.nine {
background: conic-gradient(
#ff9 0.25turn,
#009 0.25turn 0.5turn,
#999 0.5turn 0.75turn,
#900 0.75turn
) top left / 25% 25% repeat;
}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}