#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((192\.168\.1|201.110\.2(0[8-9]|1\d|2[0-3]))\.([1-9]\d?|1\d\d|2[0-3]\d|24\d|25[0-4]))$"
Local $sString = "1.2.3.4" & @CRLF & _
"69.69.69.69" & @CRLF & _
"" & @CRLF & _
"192.168.1.0" & @CRLF & _
"192.168.1.1" & @CRLF & _
"192.168.1.69" & @CRLF & _
"192.168.1.233" & @CRLF & _
"192.168.1.254" & @CRLF & _
"192.168.1.255" & @CRLF & _
"" & @CRLF & _
"201.110.207.1" & @CRLF & _
"201.110.208.1" & @CRLF & _
"201.110.208.127" & @CRLF & _
"201.110.219.123" & @CRLF & _
"201.110.223.254" & @CRLF & _
"201.110.223.255"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")