// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^((192\.168\.1|201.110\.2(0[8-9]|1\d|2[0-3]))\.([1-9]\d?|1\d\d|2[0-3]\d|24\d|25[0-4]))$").unwrap();
let string = "1.2.3.4
69.69.69.69
192.168.1.0
192.168.1.1
192.168.1.69
192.168.1.233
192.168.1.254
192.168.1.255
201.110.207.1
201.110.208.1
201.110.208.127
201.110.219.123
201.110.223.254
201.110.223.255";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}