using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((192\.168\.1|201.110\.2(0[8-9]|1\d|2[0-3]))\.([1-9]\d?|1\d\d|2[0-3]\d|24\d|25[0-4]))$";
string input = @"1.2.3.4
69.69.69.69
192.168.1.0
192.168.1.1
192.168.1.69
192.168.1.233
192.168.1.254
192.168.1.255
201.110.207.1
201.110.208.1
201.110.208.127
201.110.219.123
201.110.223.254
201.110.223.255";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}