# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^((192\.168\.1|201.110\.2(0[8-9]|1\d|2[0-3]))\.([1-9]\d?|1\d\d|2[0-3]\d|24\d|25[0-4]))$"
test_str = ("1.2.3.4\n"
"69.69.69.69\n\n"
"192.168.1.0\n"
"192.168.1.1\n"
"192.168.1.69\n"
"192.168.1.233\n"
"192.168.1.254\n"
"192.168.1.255\n\n"
"201.110.207.1\n"
"201.110.208.1\n"
"201.110.208.127\n"
"201.110.219.123\n"
"201.110.223.254\n"
"201.110.223.255")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.