#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(,.)?(M{0,4}(CM|CD|D?C{0,3})(XC|XL|L?X{0,3})(IX|IV|V?I{0,3}))$"
Local $sString = "Jon Doe" & @CRLF & _
"Jon A. Doe" & @CRLF & _
"Jon Anderson Doe" & @CRLF & _
"Jon Doe II" & @CRLF & _
"Jon Doe, IV" & @CRLF & _
"Jon A. Doe, V" & @CRLF & _
"Jon A. Doe X" & @CRLF & _
"Jon Anderson Doe, VI" & @CRLF & _
"Jon Anderson Doe VII"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")