import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(,.)?(M{0,4}(CM|CD|D?C{0,3})(XC|XL|L?X{0,3})(IX|IV|V?I{0,3}))$";
final String string = "Jon Doe\n"
+ "Jon A. Doe\n"
+ "Jon Anderson Doe\n"
+ "Jon Doe II\n"
+ "Jon Doe, IV\n"
+ "Jon A. Doe, V\n"
+ "Jon A. Doe X\n"
+ "Jon Anderson Doe, VI\n"
+ "Jon Anderson Doe VII";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}