re = /(,.)?(M{0,4}(CM|CD|D?C{0,3})(XC|XL|L?X{0,3})(IX|IV|V?I{0,3}))$/m
str = 'Jon Doe
Jon A. Doe
Jon Anderson Doe
Jon Doe II
Jon Doe, IV
Jon A. Doe, V
Jon A. Doe X
Jon Anderson Doe, VI
Jon Anderson Doe VII'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end