import re
regex = re.compile(r"(,.)?(M{0,4}(CM|CD|D?C{0,3})(XC|XL|L?X{0,3})(IX|IV|V?I{0,3}))$", flags=re.MULTILINE)
test_str = ("Jon Doe\n"
"Jon A. Doe\n"
"Jon Anderson Doe\n"
"Jon Doe II\n"
"Jon Doe, IV\n"
"Jon A. Doe, V\n"
"Jon A. Doe X\n"
"Jon Anderson Doe, VI\n"
"Jon Anderson Doe VII")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")