using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\/posts(\/[0-9]+)?$";
string input = @"/posts
/posts/1
/posts/921
/posts/3821
/posts/anylink
/posts/create
/posts/1a
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}