re = /^\/posts(\/[0-9]+)?$/m
str = '/posts
/posts/1
/posts/921
/posts/3821
/posts/anylink
/posts/create
/posts/1a
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end