// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\/posts(\/[0-9]+)?$").unwrap();
let string = "/posts
/posts/1
/posts/921
/posts/3821
/posts/anylink
/posts/create
/posts/1a
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}