$re = '/^\/posts(\/[0-9]+)?$/m';
$str = '/posts
/posts/1
/posts/921
/posts/3821
/posts/anylink
/posts/create
/posts/1a
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);