package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\/posts(\/[0-9]+)?$`)
var str = `/posts
/posts/1
/posts/921
/posts/3821
/posts/anylink
/posts/create
/posts/1a
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}