# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:(?<=^|[^\d.])(\d{1,3})(?=(?:\d{3})+(?:\D|$))|\G)(\d{3})/$1,$2/gm;t' <<< "1 10 100 1000
10000
1000.23
10032323232320.12323232"