const regex = /(?:(?<=^|[^\d.])(\d{1,3})(?=(?:\d{3})+(?:\D|$))|\G)(\d{3})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:(?<=^|[^\\d.])(\\d{1,3})(?=(?:\\d{3})+(?:\\D|$))|\\G)(\\d{3})', 'gm')
const str = `1 10 100 1000
10000
1000.23
10032323232320.12323232`;
const subst = `$1,$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);