import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(?<=^|[^\\d.])(\\d{1,3})(?=(?:\\d{3})+(?:\\D|$))|\\G)(\\d{3})";
final String string = "1 10 100 1000\n"
+ "10000\n"
+ "1000.23\n\n"
+ "10032323232320.12323232";
final String subst = "$1,$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}