re = /(?:(?<=^|[^\d.])(\d{1,3})(?=(?:\d{3})+(?:\D|$))|\G)(\d{3})/m
str = '1 10 100 1000
10000
1000.23
10032323232320.12323232'
subst = '$1,$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result