use strict;
my $str = '1 10 100 1000
10000
1000.23
10032323232320.12323232';
my $regex = qr/(?:(?<=^|[^\d.])(\d{1,3})(?=(?:\d{3})+(?:\D|$))|\G)(\d{3})/mp;
my $subst = '$1,$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";