const regex = /(?<!(?:\/\/|\*).*)((?:export|import)[\s\w*,{}]*(?=\sfrom)|export\b\s*(?:[*{]|\w\s?.+)|await import|import\.meta\.(?:env(?:\.\w+)?|resolve|url))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!(?:\\\/\\\/|\\*).*)((?:export|import)[\\s\\w*,{}]*(?=\\sfrom)|export\\b\\s*(?:[*{]|\\w\\s?.+)|await import|import\\.meta\\.(?:env(?:\\.\\w+)?|resolve|url))', 'gm')
const str = `import * as foo from 'foo'
import { foo } from 'foo'
import {
foo,
bar
} from 'foo'
import.meta.env
import.meta.env.foo
import.meta.url
import.meta.resolve
export * from './foo'
export { default } from './foo'
export {
foo,
bar
} from 'foo'
export async function
// export async function
/**
*
* @example
* export default foo = 123
*
*/
await import
export default foo
export default function foo
export default () => {
}
export class
export type`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}