use strict;
my $str = 'import * as foo from \'foo\'
import { foo } from \'foo\'
import {
foo,
bar
} from \'foo\'
import.meta.env
import.meta.env.foo
import.meta.url
import.meta.resolve
export * from \'./foo\'
export { default } from \'./foo\'
export {
foo,
bar
} from \'foo\'
export async function
// export async function
/**
*
* @example
* export default foo = 123
*
*/
await import
export default foo
export default function foo
export default () => {
}
export class
export type';
my $regex = qr/(?<!(?:\/\/|\*).*)((?:export|import)[\s\w*,{}]*(?=\sfrom)|export\b\s*(?:[*{]|\w\s?.+)|await import|import\.meta\.(?:env(?:\.\w+)?|resolve|url))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}