package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\bstyle(?:="[^"]*")?`)
var str = `style="font-family:"Open Sans", Arial, sans-serif;background-color:rgb(255, 255, 255);display:inline !important;"
style=""
style="something"
style
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}