re = /\bstyle(?:="[^"]*")?/m
str = 'style="font-family:"Open Sans", Arial, sans-serif;background-color:rgb(255, 255, 255);display:inline !important;"
style=""
style="something"
style
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end