import re
regex = re.compile(r"\bstyle(?:=\"[^\"]*\")?", flags=re.MULTILINE)
test_str = ("style=\"font-family:"Open Sans", Arial, sans-serif;background-color:rgb(255, 255, 255);display:inline !important;\"\n"
"style=\"\"\n"
"style=\"something\" \n"
"style\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")