import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bstyle(?:=\"[^\"]*\")?";
final String string = "style=\"font-family:"Open Sans", Arial, sans-serif;background-color:rgb(255, 255, 255);display:inline !important;\"\n"
+ "style=\"\"\n"
+ "style=\"something\" \n"
+ "style\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}