#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "Some Text 1\s+(?P<myfield1>.+)(\sSome Text 2|\",)"
Local $sString = "Some Text 1 <my field 1> Some Text 2" & @CRLF & _
"Some Text 1 <my field 1>"," & @CRLF & _
"Some Text 1 <my field 1> Some Text 2" & @CRLF & _
"Some Text 1 <my field 1> Some Text 2" & @CRLF & _
"Some Text 1 <my field 1>","
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")