re = /Some Text 1\s+(?P<myfield1>.+)(\sSome Text 2|\",)/
str = 'Some Text 1 <my field 1> Some Text 2
Some Text 1 <my field 1>",
Some Text 1 <my field 1> Some Text 2
Some Text 1 <my field 1> Some Text 2
Some Text 1 <my field 1>",'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end