// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"Some Text 1\s+(?P<myfield1>.+)(\sSome Text 2|\",)"#).unwrap();
let string = "Some Text 1 <my field 1> Some Text 2
Some Text 1 <my field 1>\",
Some Text 1 <my field 1> Some Text 2
Some Text 1 <my field 1> Some Text 2
Some Text 1 <my field 1>\",";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}