$re = '/Some Text 1\s+(?P<myfield1>.+)(\sSome Text 2|\",)/';
$str = 'Some Text 1 <my field 1> Some Text 2
Some Text 1 <my field 1>",
Some Text 1 <my field 1> Some Text 2
Some Text 1 <my field 1> Some Text 2
Some Text 1 <my field 1>",';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);