package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`Some Text 1\s+(?P<myfield1>.+)(\sSome Text 2|\",)`)
var str = `Some Text 1 <my field 1> Some Text 2
Some Text 1 <my field 1>",
Some Text 1 <my field 1> Some Text 2
Some Text 1 <my field 1> Some Text 2
Some Text 1 <my field 1>",`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}