# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\h+\|\h+\d+$//gm;t' <<< "adrian-strauch@t-online.de:12xxxxxx | 5
svenschalke@t-online.de:kikerxxx | 33
dennis.meinhardt@t-online.de:vxxxxxx | 169
Fabibau@t-online.de:rofxxxx | 134
anders.gerd@t-online.de:townxxx | 1"