# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\h+\|\h+\d+$"
test_str = ("adrian-strauch@t-online.de:12xxxxxx | 5\n"
"svenschalke@t-online.de:kikerxxx | 33\n"
"dennis.meinhardt@t-online.de:vxxxxxx | 169\n"
"Fabibau@t-online.de:rofxxxx | 134\n"
"anders.gerd@t-online.de:townxxx | 1")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.