const regex = /\h+\|\h+\d+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\h+\\|\\h+\\d+$', 'gm')
const str = `adrian-strauch@t-online.de:12xxxxxx | 5
svenschalke@t-online.de:kikerxxx | 33
dennis.meinhardt@t-online.de:vxxxxxx | 169
Fabibau@t-online.de:rofxxxx | 134
anders.gerd@t-online.de:townxxx | 1`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);