import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\h+\\|\\h+\\d+$";
final String string = "adrian-strauch@t-online.de:12xxxxxx | 5\n"
+ "svenschalke@t-online.de:kikerxxx | 33\n"
+ "dennis.meinhardt@t-online.de:vxxxxxx | 169\n"
+ "Fabibau@t-online.de:rofxxxx | 134\n"
+ "anders.gerd@t-online.de:townxxx | 1";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}