re = /\h+\|\h+\d+$/m
str = 'adrian-strauch@t-online.de:12xxxxxx | 5
svenschalke@t-online.de:kikerxxx | 33
dennis.meinhardt@t-online.de:vxxxxxx | 169
Fabibau@t-online.de:rofxxxx | 134
anders.gerd@t-online.de:townxxx | 1'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result