#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(opening soon)|(coming soon)|(under construction)"
Local $sString = "abcd coming soon." & @CRLF & _
"..." & @CRLF & _
"123 "414-898-7667"" & @CRLF & _
"under construction. Bill Gates. Some other text. MSFT, AAPL, AMZN. Coming soon." & @CRLF & _
"Opening later. Or may be opening soon." & @CRLF & _
"" & @CRLF & _
"Are you sure? Opening soon?" & @CRLF & _
"" & @CRLF & _
"I bet they are still under construction. The builder said that the truck is coming Soon."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")