re = /(opening soon)|(coming soon)|(under construction)/mi
str = 'abcd coming soon.
...
123 "414-898-7667"
under construction. Bill Gates. Some other text. MSFT, AAPL, AMZN. Coming soon.
Opening later. Or may be opening soon.
Are you sure? Opening soon?
I bet they are still under construction. The builder said that the truck is coming Soon.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end