import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(opening soon)|(coming soon)|(under construction)";
final String string = "abcd coming soon.\n"
+ "...\n"
+ "123 \"414-898-7667\"\n"
+ "under construction. Bill Gates. Some other text. MSFT, AAPL, AMZN. Coming soon.\n"
+ "Opening later. Or may be opening soon.\n\n"
+ "Are you sure? Opening soon?\n\n"
+ "I bet they are still under construction. The builder said that the truck is coming Soon.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}