import re
regex = re.compile(r"(opening soon)|(coming soon)|(under construction)", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("abcd coming soon.\n"
"...\n"
"123 \"414-898-7667\"\n"
"under construction. Bill Gates. Some other text. MSFT, AAPL, AMZN. Coming soon.\n"
"Opening later. Or may be opening soon.\n\n"
"Are you sure? Opening soon?\n\n"
"I bet they are still under construction. The builder said that the truck is coming Soon.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")