using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(opening soon)|(coming soon)|(under construction)";
string input = @"abcd coming soon.
...
123 ""414-898-7667""
under construction. Bill Gates. Some other text. MSFT, AAPL, AMZN. Coming soon.
Opening later. Or may be opening soon.
Are you sure? Opening soon?
I bet they are still under construction. The builder said that the truck is coming Soon.";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}