using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^Кк][Аа]|[Ии]|[Вв][Аа]|[Оо])њ([Ее][Кк]|[Ее][Зз]|[Оо][Нн]|[Уу][ГгНн])";
string substitution = @"$1нј$2";
string input = @"НЕ ТРЕБА МЕЊАТИ
кањон иње безакоњу коњу коњух коњуха коњуху коњушар коњушара коњушареву коњушари коњушарима коњушарске коњушарски коњушник коњушница коњушнице коњушници коњушницу коњушног млакоњу озакоњује баштињених баштињену бесиње близнакиње богиње буктиње вињета вињетама вињете вињети Влахиње вршњакиње глогиње голотиње гриње Гркиње гусиње дактилографкиње дворкиње Дедиње детиње детињег детињега детињем
ТРЕБА МЕЊАТИ
ањон вањезичке ињектирати ињектовати ињекција ињекције ињекцијом ињекцију ињекциони коњугација коњугирати
коњугован коњунктив коњунктива коњунктура коњункција некоњугован некоњункторан Тањуг Тањуга тањугов тањуговом Тањугу";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}