const regex = /([^Кк][Аа]|[Ии]|[Вв][Аа]|[Оо])њ([Ее][Кк]|[Ее][Зз]|[Оо][Нн]|[Уу][ГгНн])/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([^Кк][Аа]|[Ии]|[Вв][Аа]|[Оо])њ([Ее][Кк]|[Ее][Зз]|[Оо][Нн]|[Уу][ГгНн])', 'g')
const str = `НЕ ТРЕБА МЕЊАТИ
кањон иње безакоњу коњу коњух коњуха коњуху коњушар коњушара коњушареву коњушари коњушарима коњушарске коњушарски коњушник коњушница коњушнице коњушници коњушницу коњушног млакоњу озакоњује баштињених баштињену бесиње близнакиње богиње буктиње вињета вињетама вињете вињети Влахиње вршњакиње глогиње голотиње гриње Гркиње гусиње дактилографкиње дворкиње Дедиње детиње детињег детињега детињем
ТРЕБА МЕЊАТИ
ањон вањезичке ињектирати ињектовати ињекција ињекције ињекцијом ињекцију ињекциони коњугација коњугирати
коњугован коњунктив коњунктива коњунктура коњункција некоњугован некоњункторан Тањуг Тањуга тањугов тањуговом Тањугу`;
const subst = `$1нј$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);