use strict;
my $str = 'НЕ ТРЕБА МЕЊАТИ
кањон иње безакоњу коњу коњух коњуха коњуху коњушар коњушара коњушареву коњушари коњушарима коњушарске коњушарски коњушник коњушница коњушнице коњушници коњушницу коњушног млакоњу озакоњује баштињених баштињену бесиње близнакиње богиње буктиње вињета вињетама вињете вињети Влахиње вршњакиње глогиње голотиње гриње Гркиње гусиње дактилографкиње дворкиње Дедиње детиње детињег детињега детињем
ТРЕБА МЕЊАТИ
ањон вањезичке ињектирати ињектовати ињекција ињекције ињекцијом ињекцију ињекциони коњугација коњугирати
коњугован коњунктив коњунктива коњунктура коњункција некоњугован некоњункторан Тањуг Тањуга тањугов тањуговом Тањугу';
my $regex = qr/([^Кк][Аа]|[Ии]|[Вв][Аа]|[Оо])њ([Ее][Кк]|[Ее][Зз]|[Оо][Нн]|[Уу][ГгНн])/p;
my $subst = '$1нј$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";