// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"([^Кк][Аа]|[Ии]|[Вв][Аа]|[Оо])њ([Ее][Кк]|[Ее][Зз]|[Оо][Нн]|[Уу][ГгНн])").unwrap();
let string = "НЕ ТРЕБА МЕЊАТИ
кањон иње безакоњу коњу коњух коњуха коњуху коњушар коњушара коњушареву коњушари коњушарима коњушарске коњушарски коњушник коњушница коњушнице коњушници коњушницу коњушног млакоњу озакоњује баштињених баштињену бесиње близнакиње богиње буктиње вињета вињетама вињете вињети Влахиње вршњакиње глогиње голотиње гриње Гркиње гусиње дактилографкиње дворкиње Дедиње детиње детињег детињега детињем
ТРЕБА МЕЊАТИ
ањон вањезичке ињектирати ињектовати ињекција ињекције ињекцијом ињекцију ињекциони коњугација коњугирати
коњугован коњунктив коњунктива коњунктура коњункција некоњугован некоњункторан Тањуг Тањуга тањугов тањуговом Тањугу";
let substitution = "$1нј$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}