# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([^Кк][Аа]|[Ии]|[Вв][Аа]|[Оо])њ([Ее][Кк]|[Ее][Зз]|[Оо][Нн]|[Уу][ГгНн])"
test_str = ("НЕ ТРЕБА МЕЊАТИ\n"
" кањон иње безакоњу коњу коњух коњуха коњуху коњушар коњушара коњушареву коњушари коњушарима коњушарске коњушарски коњушник коњушница коњушнице коњушници коњушницу коњушног млакоњу озакоњује баштињених баштињену бесиње близнакиње богиње буктиње вињета вињетама вињете вињети Влахиње вршњакиње глогиње голотиње гриње Гркиње гусиње дактилографкиње дворкиње Дедиње детиње детињег детињега детињем\n\n"
"ТРЕБА МЕЊАТИ\n"
" ањон вањезичке ињектирати ињектовати ињекција ињекције ињекцијом ињекцију ињекциони коњугација коњугирати\n"
"коњугован коњунктив коњунктива коњунктура коњункција некоњугован некоњункторан Тањуг Тањуга тањугов тањуговом Тањугу")
subst = "$1нј$2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.