import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=\\b.{48}\\b)[A-Z0]*0[A-Z0]*";
final String string = "AUSGKAJDGAYGDKJAA0GDKJAGDJKASGDKJASGDKYQGWUDVASA\n"
+ "AUSGKAJDGAYGDKJAAAGDKJAGDJKASGDKJASGDKYQGWUDVASA\n"
+ "AUSGKAJDGAYGDKJAA0GDKJAGDJKASGDKJASGDKYQGWUDVASAB\n"
+ "AUSGKAJDGAYGDKJAA0KJAGDJKASGDKJASGDKYQGWUDVASA\n"
+ "quick brown fox AUSGKAJDGAYGDKJAS0GDKJAGDJKASGDKJASGDKYQGWUDVAS0 jumped over the fence\n"
+ "quick brown fox AUSGKAJDGAYGDKJAS0GDKJAGDJKASGDKJASGAAAAAAADKYQGWUDVAS0 jumped over the fence\n"
+ "quick brown fox AUSGKAJDGAYGDKJASBGDKJAGDJKASGDKJASGDKYQGWUDVASA jumped over the fence";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}