import re
regex = re.compile(r"(?=\b.{48}\b)[A-Z0]*0[A-Z0]*", flags=re.MULTILINE)
test_str = ("AUSGKAJDGAYGDKJAA0GDKJAGDJKASGDKJASGDKYQGWUDVASA\n"
"AUSGKAJDGAYGDKJAAAGDKJAGDJKASGDKJASGDKYQGWUDVASA\n"
"AUSGKAJDGAYGDKJAA0GDKJAGDJKASGDKJASGDKYQGWUDVASAB\n"
"AUSGKAJDGAYGDKJAA0KJAGDJKASGDKJASGDKYQGWUDVASA\n"
"quick brown fox AUSGKAJDGAYGDKJAS0GDKJAGDJKASGDKJASGDKYQGWUDVAS0 jumped over the fence\n"
"quick brown fox AUSGKAJDGAYGDKJAS0GDKJAGDJKASGDKJASGAAAAAAADKYQGWUDVAS0 jumped over the fence\n"
"quick brown fox AUSGKAJDGAYGDKJASBGDKJAGDJKASGDKJASGDKYQGWUDVASA jumped over the fence")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")